Salli tekstityksen vastata äänivalintaa

Sivustoa
		sponsoroi SatShop.fi

timppaviks

Huoltovalikon jäsen
Laitteisto
2 x Duo2 (dual T2 & S2)
OpenATV 6.3
T-90 & Triax TD-110
LG Oled 55c7v
Denon AVR-X3500H
MBR15" & iPad Pro
En tiedä onko vain OpenATV (6.3 ja 6.4) ja Vu+ Duo2 ongelma, mutta ainakin itsellä kyseiset imaget mainitussa poksissa tekee seuravaa.

Automaattisessa kielivalinnassa oleva asetus "Salli tekstityksen vastata äänivalintaa" nollautuu / muuttuu arvoon "Ei mitään" aina poksin uudelleen käynnistyksessä. Tämä aiheuttaa sen, että kanavilla joilla ääni sekä tekstitys lähetetään "Suomi"-tunnisteella ei toimi haluamallani tavalla ellei asetusta käy muuttamssa takaisin "Suomi" valintaan aina uudellenkäynnistyksen jälkeen.

Esim. MTV3 HD (antenniverkko) kanavalta tuleva ohjelma, jossa puhuttu kieli on englanti näkyy ääniraitavalinnassa "Suomi"-tunnisteella ja ilman tuota vastaavuuden sallimista poksi ei näytä ohjelmalle tekstitystä. En tarkalleen tiedä mistä versiosta alkaen "nollaantuminen" on alkanut, mutta aina näin ei ole ollut.

Settings tiedostossa löytyy kohta "config.autolanguage.equal_languages=1" Tämä arvo ei käynnistyksessä muutu, mutta arvon käsin muuttaminenkaan ei vaikuta uudelleen käynnistyksen jälkeiseen "nollaantumiseen". Eli riippumatta tuon kohdan arvosta GUI:ssa näkyvä valinta on jokaisen käynnistyksen jälkeen "Ei mitään" ja tekstitys ei pelaa halutulla tavalla.

Löysin seuraavan ratkaisumallin ja ainakin pienen testini perusteella tuntuisi toimivan. Eli tehdään scripti joka käy pakottamassa tuon asetuksen uudelleen käynnistyksessä. Jollain voi olla parempikin ratkaisumalli ja parasta tietysti olisi kommentoida tonne OpenATV foorumille, mutta itsellä tulee vastaan kielimuuri

Tämä ei varmasti ole riittävä ohje ihan aloittelijalle, mistä foorumilla ollut puhetta, mutta ennenkuin joku viisaampi asian vahvistaa en uskalla ihan rautalanka ohjetta tehdä.

Asenna curl
Koodi:
opkg update && opkg list | grep curl
opkg install curl
Tee scripti. Olettamalla, että Suomi on 1. äänivalinta
Koodi:
nano /etc/init.d/subtitle-equal.sh

#!/bin/sh
curl --noproxy '*' --data value=1 "http://127.0.0.1/api/saveconfig?key=config.autolanguage.equal_languages"
exit 0
Muuta scriptin oikeudet
Koodi:
chmod 755 /etc/init.d/subtitle-equal.sh
Suorita scripti poksin käynnistyksessä
Koodi:
crontab -e
@reboot sleep 40 && /etc/init.d/subtitle-equal.sh
 
Viimeksi muokattu:
Ylös